Empty/blank item while creating a Report
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Empty/blank item while creating a Report

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Article ID: 389664

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Updated On: 03-03-2025

Products

CA Client Automation CA Client Automation - IT Client Manager

Issue/Introduction

While creating a report in DSM Reporter, can be seen an empty item in the list of available inventory modules:

Environment

Client Automation 14.5 and above

Cause

Generally speaking, this kind of issue happens when an Additional Inventory module has been created and it brings some wrong data because of a problem in the script itself. This is an example of how a customer inventory module incorrectly created can create an blank/empty value:

Resolution

In order to be sure that no records of this incorrect inventory modules are retain, it's suggested to do the following:

1.- Be sure that the Additional Inventory module is unlinked or deleted from the environment.
2.- On the problematic Agent, stop CAF services (caf stop & caf kill all)
3.- Delete this Agent from DSM Explorer.
4.- Back to the Agent, navigate to ..Agent\units\00000001\ and delete "uam" folder.
5.- Start CAF services, this will trigger the registration of the Agent with the SS, re creating this machine on DSM Explorer.
6.- Run this command to trigger a full inventory recollection and fill up all inventory info: 

caf start amagent args /RESCAN_INVENTORY /RESCAN_SOFTWARE /COLLECT