Upgrade to version 8.14.x does not complete on primary node
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Upgrade to version 8.14.x does not complete on primary node

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Article ID: 389519

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Updated On:

Products

VCF Operations/Automation (formerly VMware Aria Suite)

Issue/Introduction

  • Upgrading Aria Operations for Logs from 8.12.x to 8.14.x does not complete
  • The primary node reboots, but the loginsight service does not run
  • using top command, it is noted that the loginsight service is constantly restarting every second

Environment

VMware Aria Operations for Logs 8.12.x

Cause

The internal loginsight-config.xml is not updated with the correct service start parameters during the upgrade.

Resolution

  1. Revert all Aria Operations for Logs nodes to the snapshot that was taken prior to the upgrade attempt.

  2. Navigate to https:// ip-or-fqdn /internal/config and log in as a user with administrative rights.

    Note: Replace ip-or-fqdn with the IP or FQDN of the Aria Operations for Logs primary node

  3. Click the Show all settings checkbox at the bottom of the page.

  4. Delete the line that starts with
    <service name="Daemon" jvm-args=
  5. Retry the upgrade to 8.14.1