SEPM Home page displays error: Query Failed - Unexpected error in server logs
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SEPM Home page displays error: Query Failed - Unexpected error in server logs

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Article ID: 389476

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Updated On: 03-18-2025

Products

Endpoint Protection

Issue/Introduction

On login to Symantec Endpoint Protection Manager (SEPM), the Home page shows a "Query Failed" message.

Following error is found in scm-server-0.log:
2025-02-23 00:00:41.527 THREAD 632086 WARNING: DatabaseUtilities>>executeUpdateByChunk Exception:com.microsoft.sqlserver.jdbc.SQLServerException: Internal Query Processor Error: The query processor encountered an unexpected error during execution (HRESULT = 0x80040e19).

Environment

SEPM 14.3 RU1+

Cause

This error is indicating an issue with index corruption on SEPM database tables.

Resolution

Take a backup of SEPM database (default sem5). Then perform the below steps:

  • Stop the SEPM services.
  • Open Microsoft SQL Server Management Studio (SSMS).
    If the database is on same server (SQL Express) and SSMS is not installed, need to install it first to proceed with the next steps.
  • Expand Databases> sem5> Tables
    - Scroll down and click on dbo.SEM_AGENT, expand it and Right click on Indexes
    Click Disable All, Rebuild All, Reorganize All.
  • Restart the SEPM service.
  • Login to SEPM console.

Additional Information