vSAN -- Unmounted drives may not allow for Disk Group removal
search cancel

vSAN -- Unmounted drives may not allow for Disk Group removal

book

Article ID: 389435

calendar_today

Updated On:

Products

VMware vSAN

Issue/Introduction

One or both of the following Symptoms do apply:

 

  • When attempting to remove a vSAN Disk Group from the command line, the removal fails with the error:

esxcli vsan storage remove -s #######

Unable to remove device: Disk mapping is not mounted on this host: #######

 

  • Using SDDC Manager to remove a Host without cleaning up its vSAN Disk Group(s) can cause this.
When adding a Host to an existing vSAN cluster via SDDC Manager might fail if there are existing partitions on the Disk(s) it's trying to claim. 
The message in the SDDC Host Add screen is:  vSAN Partition found on the host, needs clean-up.

 

Environment

vSAN ( All Versions )

 

Cause

Sometimes, in situations where vSAN Disk Groups are defined but not mounted, the vSAN Disk Groups cannot be removed. 
 
The vSAN Disk Group(s) and the disks that make up the Disk Group(s) must be mounted in order to be deleted.
The System is not capable of deleting vSAN Disk Group(s) that are not mounted. 
 
 

Resolution

1.) Check for any existing vSAN Disk Group(s) on the vSAN Host by running the following command on the affected vSAN Host(s):

vdq -iH

 

Example of an existing vSAN Disk Group:

[

   {

      "SSD" : "#######",

       "MD" : [

              "naa.########",

              "naa.########",

              "naa.########",

              "naa.########"

              ]

   }

 

2.) Check the Mount Status of the listed vSAN Disk Group(s) from 1.) by running the following command:

vdq -q

If a vSAN Disk is not mounted, it shows: Reason:  Not mounted on this host

 

3.) Compare the outputs from 1.) & 2.) to identify to which vSAN Disk Group(s) all vSAN Disk(s) belong showing as Not mounted on this host

 

4.) Attempt to mount the affected vSAN Disk Group by running the following command with the SSD listed from 1.)

esxcli vsan storage diskgroup mount -s ########

 

5.) Repeat Step 2.) to validate the mount status (= vSAN Disk(s) should not show anymore: Not mounted on this host )

 

6.) Remove the vSAN Disk which was mounted via Step 4.) by executing the following command:

esxcli vsan storage remove -s #######

 

7.) If previously received the error in SDDC Manager (= as shown in Section Issue/Introduction):

Try again to add the Host via SDDC Manager

 

Additional Information

If assistance is required, please open a Ticket with VMware by Broadcom Support.