"PBM error occurred during PreCreateCheckCallback: No version for VMODL calls" while creating a virtual machine/vApp from vCenter/VMware Cloud Director
search cancel

"PBM error occurred during PreCreateCheckCallback: No version for VMODL calls" while creating a virtual machine/vApp from vCenter/VMware Cloud Director

book

Article ID: 389333

calendar_today

Updated On:

Products

VMware vCenter Server 7.0 VMware vCenter Server 8.0

Issue/Introduction

Symptoms:

  • When attempting to select a destination datastore during a virtual machine deployment, the process fails with the following error "Cannot connect to profile-driven storage service."



  • Create vApp from VCD fails with error "No version for VMODL calls"
  • After finishing the create VM wizard, the create VM operation will fail with the below error -

A general system error occurred: PBM error occurred during PreCreateCheckCallback: No version for VMODL calls to <<last binding: <<TCP 'XXX.0.0.1 : 44336'>, <TCP 'XXX.0.0.1 : 1080'>> >, /pbm/sdk>

Environment

VMware vCenter server 8.x
VMware vCenter server 7.x
VMware Cloud Director 10.x

Cause

  • This issue occurs when the Profile-Driven Storage Service (vmware-sps) on the vCenter Server is stopped.

  • To verify the service status, log in to the vCenter Server Appliance (VCSA) via SSH and run: service-control --status --all, look for the status of the vmware-sps service in the output.

Resolution

To resolve this issue:

  1. Connect to the vCenter Server Appliance via SSH.
    (If SSH is disabled, enable it from the VAMI interface: https://<vcenter-fqdn>:5480)

  2. Start the Profile-Driven Storage Service by running the following command: service-control --start vmware-sps



  3. Once the service has successfully started, retry the VM deployment.

Additional Information

Ensure that all vCenter Server services are running as expected: service-control --status --all