Workload Agent cannot start due to Permission denied on lock file
search cancel

Workload Agent cannot start due to Permission denied on lock file

book

Article ID: 389271

calendar_today

Updated On:

Products

ESP dSeries Workload Automation - System Agent (dSeries) CA Workload Automation AE - System Agent (AutoSys) Workload Automation Agent

Issue/Introduction

The user may see following error when starting agent.

Error opening lock file 13 (Permission denied)

 

Environment

Workload Automaton Agent: Any

OS: UNIX/Linux

Cause

The user that starts the agent does not have permission on .lock file.   The lock file is in the agent directory.

Resolution

Start the agent as root.  If root user cannot be used, then delete the .lock as root.  Then start the WA agent as the user.  The files and directories owner may need to be changed to the user that is starting the agent.