nametoip error for old name after renaming the hub robot
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nametoip error for old name after renaming the hub robot

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Article ID: 389251

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Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM) CA Unified Infrastructure Management On-Premise (Nimsoft / UIM) CA Unified Infrastructure Management SaaS (Nimsoft / UIM)

Issue/Introduction

After renaming a robot which is also a remote hub, I am seeing errors in the remote hub log that reference the old name.

Example:

/ExampleDomain/HubName/old_robot_name/  was renamed to /ExampleDomain/HubName/new_robot_name/

error:

 name to IP failed for /ExampleDomain/HubName/old_robot_name/hub (not found)

I do not see anything in the hub.cfg or robot.cfg that references this name but the error persists.

 

Environment

  • DX UIM - Any Version
  • hub with renamed hub-robot

Cause

discovery_server cached hub scan

Resolution

  • This error is likely caused by the discovery_server which still has the old name cached and is trying to scan the hub.
  • Deactivate discovery_server and then activate it and the error should resolve.