Org admin users are unable to set the "Applied to" Interface under edit NAT rules section using IP Spaces
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Org admin users are unable to set the "Applied to" Interface under edit NAT rules section using IP Spaces

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Article ID: 389216

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Updated On:

Products

VMware Cloud Director

Issue/Introduction

Org admin users are unable to set the "Applied to" Interface under edit NAT rules using IP Spaces. The NAT rules do not populate.
As a result, Tenants are unable to set the "Applied to" Interface on NAT rules using IP Spaces. Sys admin have to manually update the NATs to apply only to their Internet Uplinks.

Environment

VMware Cloud Director 10.6.x

VMware Cloud Director 10.6.0.x

Cause

This is due to a known UI issue. 

Resolution

This issue is resolved in VMware Cloud Director 10.6.1.1, available at Broadcom Downloads

To workaround, use API to update NAT rule - see : Broadcom Developer portal Update NAT Rule

Additional Information

To reproduce issue : 

  • create multiple ipspace (can be public)
    create a provider gateway -> private to one org
    add uplinks to provider gateway with interfaces
    go to NAT and Firewall
    enable 'Provider and Edge gateways' 
    go to Service -> NAT
    create new rule
    an api call is triggered to fetch all ip space uplinks
    select -> Advanced Settings -> 'Applied To' 
    all uplinks of ip space are listed
  • go to VCD provider -> Administration -> Tenant Access
    go to Right Bundles -> Default set of tenant rights
    Enable 'Provider Gateway Services' view and manage rights
    publish
    go to Roles -> Organization Administrator 
    Enable 'Provider Gateway Services' view and manage rights
    publish
  • create a vdc, edge and org admin user
    login as orgadmin
    go to Networking -> Provider gateway
    go to Service -> NAT
    create new rule
    select -> Advanced Settings -> 'Applied To' 
    nothing happens on click