VCF Bringup fails with error VCF_VSPHERE_VCENTER_INSTALLATION_FAILED due to NTP issue
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VCF Bringup fails with error VCF_VSPHERE_VCENTER_INSTALLATION_FAILED due to NTP issue

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Article ID: 389172

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Updated On:

Products

VMware SDDC Manager VMware Cloud Foundation 5.x

Issue/Introduction

  • The following error can be seen during Bringup:

    VCF_VSPHERE_VCENTER_INSTALLATION_FAILED
    vCenter installation failed. Check logs for more details.
    com.vmware.vcf.common.util.VsphereRuntimeException:vCenter installation failed.
    Check logs for more details.
  • Bringup logs contains errors similar to the excerpt below:

    vcf-bringup-debug.log
    LocalProcess INFO: yyyy-mm-dd hh:mm:ss - ==========VCSA Deployment Progress Report==========         Task: Install
    LocalProcess INFO: yyyy-mm-dd hh:mm:ss - required RPMs for the appliance.(FAILED 0/100)    -                  Error:
    LocalProcess INFO: yyyy-mm-dd hh:mm:ss - Failed to set the time via NTP. Details: Failed to sync to NTP servers.. Code:
    LocalProcess INFO: yyyy-mm-dd hh:mm:ss - com.vmware.applmgmt.err_ntp_sync_failed                 Resolution: Verify that
    LocalProcess INFO: yyyy-mm-dd hh:mm:ss - provided ntp servers are valid.                 Error: Could not set up time
    LocalProcess INFO: yyyy-mm-dd hh:mm:ss - synchronization.                 Resolution: Verify that provided ntp servers
    LocalProcess INFO: yyyy-mm-dd hh:mm:ss - are valid.
    LocalProcess INFO: yyyy-mm-dd hh:mm:ss - The VCSA deployment has failed VCSA Deployment Start Time:
    LocalProcess INFO: yyyy-mm-dd hh:mm:ss - 1970-01-01T00:00:00.000Z VCSA Deployment End Time: 1970-01-01T00:00:00.000Z

    rpmInstall.json
    {
        "progress": 0,
        "progress_message": null,
        "status": "error",
        "info": [],
        "warning": [],
        "question": null,
        "error": {
            "detail": [
                {
                    "id": "install.setnet.set.timesync.ntp",
                    "translatable": "Failed to set the time via NTP. Details: %(0)s",
                    "args": [
                        "Failed to sync to NTP servers.. Code: com.vmware.applmgmt.err_ntp_sync_failed"
                    ],
                    "localized": "Failed to set the time via NTP. Details: Failed to sync to NTP servers.. Code: com.vmware.applmgmt.err_ntp_sync_failed"
                },
                {
                    "id": "install.setnet.set.timesync",
                    "translatable": "Could not set up time synchronization.",
                    "localized": "Could not set up time synchronization."
                }
            ],
            "componentKey": "setnet",
            "problemId": null,
            "resolution": {
                "id": "install.setnet.set.timesync.ntp.res",
                "translatable": "Verify that provided ntp servers are valid.",
                "localized": "Verify that provided ntp servers are valid."
            }
        },
        "start_time": null,
        "end_time": null
    }

Environment

VMware Cloud Foundation 5.x

Cause

This is a time synchronization issue that may be caused by one or more of the following reasons:

  • One or more NTP servers are not responding correctly over the NTP protocol (UDP port 123).

  • There is a network connectivity issue between the vCenter Server and the configured NTP server(s).

  • The vCenter Server's time is not in sync with the ESXi host(s).

  • Firewall settings are blocking Network Time Protocol (NTP) traffic on port 123.

Resolution

Verify vCenter NTP configuration.

You can check from the appliance shell using the command:

com.vmware.appliance.ntp.get



Confirm that vCenter is receiving time by issuing the "ntpq -p" command

Ensure that NTP traffic over UDP port 123 is allowed through the firewall between vCenter and the NTP servers.

Additional Information