Slow response in NetOps Portal GUI when selecting menus and dashboards
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Slow response in NetOps Portal GUI when selecting menus and dashboards

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Article ID: 389161

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Updated On:

Products

Network Observability CA Performance Management

Issue/Introduction

In general navigation of the Portal interface,  it exhibits a lag when clicking between pages - it can take a few seconds to load the header/drop down menus before they become available to interact with.

Environment

DX NetOps CA Performance Management (CAPM) all currently supported releases

Cause

Inadequate memory resources allocated to one or more of the Portal processes.

Resolution

Increase the memory allocation for Portal services as per:

TechDocs : DX NetOps 24.3 : Modify Maximum Memory Usage for NetOps Portal

Check what the values are first for the services. By default, they're set to:

DM (caperfcenter_devicemanager):

/opt/CA/PerformanceCenter/DM/conf$ grep wrapper.java.maxmemory wrapper.conf

wrapper.java.maxmemory=5314

PC (caperfcenter_console):

/opt/CA/PerformanceCenter/PC/conf$ grep wrapper.java.maxmemory wrapper.conf

wrapper.java.maxmemory=5314

EM (caperfcenter_eventmanager):

/opt/CA/PerformanceCenter/EM/conf$ grep wrapper.java.maxmemory wrapper.conf

wrapper.java.maxmemory=7971

sso (caperfcenter_sso):

/opt/CA/PerformanceCenter/sso/conf$ grep wrapper.java.maxmemory wrapper.conf

wrapper.java.maxmemory=1024

If you only see a few seconds slow response in menu generation, but not in dashboards or views, then you may only need to increase the value for PC (caperfcenter_console) from 5314 to 8192. 

So start by increasing the value of

wrapper.java.maxmemory=8192

in the file:

/opt/CA/PerformanceCenter/PC/conf/wrapper.conf

The restart the services on portal.

If Dashboards are also slow in loading, then this can be caused by slow query responses from the Data Aggregator, in which case you can also try to increase the memory allocation for the DM

/opt/CA/PerformanceCenter/DM/conf/wrapper.conf