Failed over Virtual Machines cannot power on due to inaccessible storage in VMware Cloud Director Availability
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Failed over Virtual Machines cannot power on due to inaccessible storage in VMware Cloud Director Availability

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Article ID: 389118

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Updated On:

Products

VMware Cloud Director

Issue/Introduction

  • Performing a failover or test failover of a replication in VMware Cloud Director Availablity 4.7.0 or later results in a virtual machine that cannot power on due to inaccessible disks or virtual machine configuration files.
  • The storage policy contains datastores that cannot be accessed by all hosts in the destination clusters. For example, a storage policy that contains two vSAN datastores that are only visible to their respective clusters.
  • An error may occur for migration or failovers with: The provided recovery settings are not compatible with replication placement. Invalid entry: 'deviceChange[0].device.backing.fileName'

  • When working with replications in VMware Cloud Director Availability, a warning similar to the following is encountered:

    Provided replication placement will result in unrecoverable replication. Make sure the provided storage is accessible.

Environment

VMware Cloud Director Availability 4.7.x

Cause

With the release of VMware Cloud Director Availability 4.7.0, replication tracking placement was introduced when using VMware Cloud Director 10.5.1 or later. Unlike the legacy placement solution utilizing independent disks, this permits the configuration files and each of the disks to be independently placed on separate datastores. Each placement decision is performed independently in coordination with VMware Cloud Director and all datastores in the configured storage policy are viable targets. Thus, items may be placed on separate datastores that are inaccessible to each other.

Resolution

This is a known limitation when using replication tracking placement. For items that are impacted, please use the following procedure:

  1. Remove the impacted replications.
  2. Adjust the storage policy so that all datastores included are accessible to all clusters, or use a storage policy limited to datastores accessible only by a single cluster.
  3. Recreate the replications with the corrected storage policy.

If there are limitations that would prevent this procedure from being performed, please contact Broadcom Support and note this Article ID (389118) in the problem description. For more information, see Creating and managing Broadcom support cases.

Additional Information

For additional information regarding replication tracking placement, please refer to the following:

Replication tracking placement solution