DVS health check shows VLAN 0 not supported, but VLAN 0 is not configured on any port groups
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DVS health check shows VLAN 0 not supported, but VLAN 0 is not configured on any port groups

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Article ID: 389108

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Updated On:

Products

VMware vSphere Essentials Plus VMware vSphere Foundation VMware vSphere Standard

Issue/Introduction

VLAN 0 may show up in a DVS health check even though it is not configured on any DVS port groups or NSX segments.

This occurs when NSX is installed in the environment and overlay networks are used.

Environment

VMware vSphere
VMware NSX-T Data Center

Cause

NSX overlay segments (VNI) are not properly excluded from the VLAN probe in DVS health check as intended.

Resolution

There is currently no fix for this issue.  It will be addressed in a future patch.

Workaround:

  1. Browse to a vDS in the vSphere Web Client.
  2. Click the Configure tab.
  3. Under Settings select Health Check.
  4. To enable or disable health check, click Edit.
  5. Select from the dropdown to disable health check options.
    The options include:
    • VLAN and MTU: Reports the status of distributed uplink ports and VLAN ranges
    • Teaming and Failover: Checks for any configuration mismatch between ESXi and the physical switch used in the teaming policy.
  6. Click OK.

Additional Information

Enabling vSphere Distributed Switch health check in the vSphere Web Client