VM overrides not visible in vSphere client on one or more clusters
search cancel

VM overrides not visible in vSphere client on one or more clusters

book

Article ID: 388989

calendar_today

Updated On:

Products

VMware SDDC Manager VMware vCenter Server 8.0

Issue/Introduction

When the user selects Cluster object --> Configure --> VM Overrides there are no details visible for any VM Overrides. This is despite the fact that VM Overrides details were visible and manageable previously.

In this view the user should be able to select a VM from the list provided and select to edit the VM Overrides details.

However this functionality is missing and the override settings cannot be managed.

Reviewing the dataservice log on vCenter you observe log entries similar to below:

[YYYY-MM-DDTHH:MM:SS.SSSZ] [WARN ] data-service-pool-780        70063039 101588 200147 TaskExecutor [queryId: qb-85656:h5ui-
getData:com.vmware.vsphere.client.clusterui.model.configuration.VmOverridesData:1931023000] Data Service execution for task:
 Property 'vmOverrides' was fetched by 'RiseToVisePropertyProviderAdapter' has failed java.lang.IllegalStateException: Prope
rty provider method 'getVmOverrides' of 'com.vmware.vsphere.client.clusterui.impl.VmOverridePropertyProvider' threw exception
Caused by: java.lang.NullPointerException: null

at com.vmware.vsphere.client.clusterui.util.VmOverridesUtil.getVmMonitoringSensitivityValue(VmOverridesUtil.java:980)
at com.vmware.vsphere.client.clusterui.util.VmOverridesUtil.instantiateVmOverridesListItem(VmOverridesUtil.java:543)
at com.vmware.vsphere.client.clusterui.util.VmOverridesUtil.getVmOverrideItem(VmOverridesUtil.java:393)

Environment

VMware vSphere vCenter Server 8.x

Cause

The issue is caused due to some VM Override settings being unset, which is not handled properly in the UI code.
The problematic properties are:

failureInterval
maxFailureWindow
maxFailures
minUpTime

Resolution

This issue is fixed in vCenter Server 8.0 Update 3e

Please refer to VMware vCenter Server 8.0 Update 3e Release Notes

If you have any further queries related to the issue, please open a support request and we will assist.

Please see Creating and managing Broadcom support cases

The request must be opened using Broadcom Support Portal

Additional Information