Diagnostics for VMware Cloud Foundation: Missing Log Based Findings
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Diagnostics for VMware Cloud Foundation: Missing Log Based Findings

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Article ID: 388952

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Updated On:

Products

VMware Aria Suite

Issue/Introduction

There have been reported instances of Log Based Findings not appearing even when performing the below testing steps outlined in Questions and Answers for Diagnostics for VMware Cloud Foundation

 

Q: What are the steps to trigger a log based finding?

A: To trigger a Log Based findings do the following.

  1. SSH to your esxi host.
  2. tail /var/log/vodb.log and grab the date/time of the last log entry.
  3. Paste the time and date in the following command and execute this command.
    • logger -t vobd -p info "###DATETIME### [vmfsCorrelator] 1833910567385us: [esx.problem.vmfs.heartbeat.timedout] manually added via logger"
  4. tail /var/log/vobd.log to confirm the command is added.
  5. wait 5 minutes for the logs to make it to Operations and Operations for logs.
  6. Under Diagnostics Findings --> Overall Findings --> Click refresh and choose your vCenter.
  7. After this refresh you should see a log based finding for vSphere_HostConnectivity_KB_1009557e

 

Environment

VMware Cloud Foundation 5.2

Cause

There is a host name difference between what is configured in Operations and what is configured in Operations for Logs. Operations gets the host name of the ESXi host from vCenter where Operations for Logs gets the host name from the ESXi host.

Resolution

The most common reason for this host name difference is that the DNS domain information is missing on the ESXi host. 

 

To resolve this please follow these steps for every host in your environment. 

  1. Open the vCenter and browse to your ESXi host
  2. Select Configuration
  3. Select TCP/IP Configuration
  4. Edit the Default Stack
  5. Under DNS Configuration enter the proper domain name under the domain field to match the FQDN defined for the ESXi host under the vCenter