Devices fail to detect on vmhba of ESXi host running on Dell PowerEdge server
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Devices fail to detect on vmhba of ESXi host running on Dell PowerEdge server

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Article ID: 388926

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Updated On:

Products

VMware vSphere ESXi

Issue/Introduction

Symptoms:

  •  No devices or paths detected in one or more HBA:
  •  All of sudden the access has been lost, vmhba status shows online
  • Rescan of the storage adapter (HBA) fails to detect the devices.




     

 

  •  The server hardware is of DellEMC PowerEdge MX740c, a blade server.
  •  lspci command in ESXi shell populates both the HBAs (in this instance it is vmhba3 and vmhba4):

Environment

vSphere ESXi 7.x

Cause

"Remote Port" (RPORT) not online, which is a port on the switch that connects to a remote device (like an ESXi host, storage device, etc.), is not currently active or reachable.:

  • /var/run/log/vmkernel.log reports following errors of the RPORT not being online:

    2025-02-15T23:12:49.855Z cpu59:4585774)qedf:vmhba3:qedfc_checkTarget:2716:Info: RPORT 0x4313ec772440(0x4) is not ONLINE
    2025-02-15T23:12:49.855Z cpu59:4585774)qedf:vmhba3:qedfc_checkTarget:2716:Info: RPORT 0x4313ec772940(0x4) is not ONLINE
    2025-02-15T23:12:49.855Z cpu59:4585774)qedf:vmhba3:qedfc_checkTarget:2716:Info: RPORT 0x4313ec773310(0x4) is not ONLINE
    2025-02-15T23:12:49.855Z cpu59:4585774)qedf:vmhba3:qedfc_checkTarget:2716:Info: RPORT 0x4313ec772cf0(0x4) is not ONLINE

This can happen for several reasons, such as:

  1. Link Failure: The physical connection between the switch and the remote device might be down, either due to a cable issue, port failure, or improper configuration.
  2. Port Configuration: The RPORT may not be configured correctly, or the settings might not match between the switch and the device it connects to.
  3. Zoning Issues: In a Fiber Channel network, zoning is used to define which devices can communicate with each other. If zoning isn't correctly set up, it might prevent the RPORT from coming online.
  4. Firmware/Software Issues: There could be a bug or incompatibility in the switch’s firmware or the remote device’s configuration that’s preventing the RPORT from being brought online.
  5. SAN Fabric Issues: If the switch is part of a larger SAN fabric, misconfigurations or failures in the fabric might prevent the RPORT from becoming active.

Resolution

  1. Disable and re-enable the Fabric port on the PowerEdge server using DellEMC OpenManage Enterprise (OME) console.

  2. Rescan HBA adapter and validate if devices are detected.
    (vSphere Client > ESXi host > Configure > Storage Adapters > Select the 'vmhbaX' that failed to detect any devices > Click on 'Rescan Adapter')

  3. If the above steps don't help, please engage the Switch Vendor to investigate further on why the RPORT reports Not Online.