Resolving Log Streaming Issues After Network interruptions Between the SE and the External Server
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Article ID: 388835
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Updated On:
Products
VMware Avi Load Balancer
Issue/Introduction
In some network environments, the streaming of logs to an external server may fail if there is a network disruption causing a transient connectivity loss.
This issue typically occurs when syslog over TCP is configured for log streaming.
After the connectivity is restored, the connection to the external server does not automatically re-establish, leading to the failure of log streaming.
Cause
When there is a sudden disruption in connectivity such as a network outage, power failure, or other unforeseen events, the connection between the SE and the external server is abruptly terminated.
Once the connectivity is restored, the detection mechanism currently in place does not automatically reconnect to the server
As a result, log streaming remains disconnected, and the logs are not sent to the server
Resolution
Workaround:
Locate the Analytics profile associated with the log streaming configuration.
Adjust the Maximum Logs knob setting to some other value and save it to force a reconnection attempt.
By adjusting this setting, the system may trigger a reattempt at streaming logs, thereby allowing for the reconnection to the external log server in case of connectivity restoration.
The automatic reconnection feature is now included in the latest versions to ensure that the streaming engine will reconnect to the external log server once connectivity is restored, even after abrupt network disruptions.
Kindly upgrade to one of the below Versions or above for a permanent fix