Unable to Re-create VM Tags After Enhanced Linked Mode is Split
search cancel

Unable to Re-create VM Tags After Enhanced Linked Mode is Split

book

Article ID: 388786

calendar_today

Updated On:

Products

VMware vCenter Server

Issue/Introduction

After splitting Enhanced Linked Mode (ELM), it is possible for previously existing Tags that were visible pre-split to not appear in the split vCenter's inventory. 

 

Symptoms: 

  • Attempting to re-create a tag results in the error  "A tag with that name exists in category <CATEGORY>"

Environment

VMware vCenter Server 7.x

VMware vCenter Server 8.x

Cause

If Enhanced Linked Mode is not split properly, vSphere inventory objects may not exist for tags while the VMDIR entries for them still do exist. The reason the tags cannot be re-created so they are visible in the inventory is because they technically exist already, resulting in the error "A tag with that name exists in category <CATEGORY"

Resolution

To resolve this issue, you will need to clear out VMDIR of the orphaned VM Tag entries. To do this, we will need to utilize a tool such as JXPLORER, which this guide outlines the use of to accomplish this.

  1. Log into your vCenter with JXPLORER following this KB - https://knowledge.broadcom.com/external/article/301632/using-jxplorer-to-connect-to-the-vsphere.html
  2. Navigate down the tree to Services > Tagging
  3. The items listed below Tagging will be your Tag categories. You can identify which one is which using the screenshot below to reference the vmwTaggingCategoryName field:



  4. Expand the appropriate Category to view the individual tags within that category. You can identify which tag is which by the vmwTaggingTagName field:



  5. Right-click the tags you want to delete and click Delete 




  6. You should now be able to re-create your Tags without issue.