The DA will not connect to the Portal after a fresh installation
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The DA will not connect to the Portal after a fresh installation

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Article ID: 388781

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Updated On:

Products

Network Observability

Issue/Introduction

After installing a fresh, clean DX NetOps Performance Manager env with Portal, DA and a 3 node Vertica cluster all running on RHEL 8, the DA will not connect to the Portal.

The following errors are seen in the /opt/CA/PerformanceCenter/PC/logs/PCService.log file:

ERROR | qtp1113069761-250        | 2025-02-19 15:37:05,600 | com.ca.im.portal.api.services.datasource.DataSourcePoll          
      | Received WebServiceException from version check for data source Data Aggregator@da.  CAUSE=java.net.ConnectException: No route to host. MESSAGE=Could not send Message..  Returning DS_COMM_FAILURE result.

ERROR | Status Poller-thread-1   | 2025-02-19 15:42:14,655 | com.ca.im.portal.api.common.services.impl.rest.RestHelper        
      | Failed to send rest GET http://xxx.xxx.xxx.xxx:8581/rest/dataaggregator

Environment

Version: Any
Component: Portal

Cause

There is a communication issue between the Portal and DA systems.

 

Resolution

Check for the following:

  • iptables configured on the DA or Portal systems preventing communication
  • firewalld running on the DA or Portal systems preventing communication
  • Firewall between the DA and Portal systems preventing communication
  • Hostname resolution from Portal to DA and Portal to DA
  • A routing issue between the DA and Portal systems