Jobs are stuck in Waiting for Queue Slot status despite no active executions on a Queue.
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Jobs are stuck in Waiting for Queue Slot status despite no active executions on a Queue.

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Article ID: 388746

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Updated On:

Products

CA Automic Workload Automation - Automation Engine CA Automic One Automation Automic SaaS

Issue/Introduction

Jobs with a maximum queue limit fail to execute and are stuck with the status "Waiting for Queue Slot", even though there are no pending executions in the queue. This issue arises when the maximum queue limit is set to 1 or 2, However does not occur when the queue capacity is set to 10 or more.

Environment

Release: 21.0.11, 24.1.0

Component: Automation Engine

Cause

The issue has been confirmed to be a bug by our Dev team.

Resolution

Update to a fix version listed below or a newer version if available.

Fix version:

Component(s): Automation Engine

Automation.Engine 21.0.13 HF1 - Available

Automation Engine 24.3.0 HF3 -  Available

Additional Information

Defect ID: DE161092

Defect Desc: A bug was fixed where sometimes a task wouldn't execute even if there were slots available in the queue.