Console Inaccessible with Demo Expired Message after 8.11 Server Upgrade
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Console Inaccessible with Demo Expired Message after 8.11 Server Upgrade

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Article ID: 388701

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Updated On:

Products

Carbon Black App Control

Issue/Introduction

After upgrading to Server version 8.11.0 the Web Console displays error message similar to:

Your Demo of Carbon Black App Control has expired. Contact Global Customer Assistance to purchase a copy.

Environment

  • App Control Server: 8.11.0

Cause

The Server License file that was applied before the upgrade to Server 8.11.0 was already expired.

Resolution

A valid server license will be required to resolve the Demo Expired message.

  1. Log in to the Broadcom Support Portal and download your current Server License.
  2. Follow these steps to import the non-expired Server License:
    1. Stop the App Control Server and App Control Reporter services.
    2. Run SQL Server Management Studio as the Carbon Black Service Account.
    3. Open the .lic file in a text editor and copy the content
    4. Update the following SQL query by pasting the license value within the single quotes:
      USE das; EXECUTE dbo.UpdateLicense 'UPDATE VALUE FROM LIC', '0'
    5. Start the App C Server and Reporter services and attempt to access the console again

In case the current license is not available for download in the Support portal:

  1. Open a Non-technical Case for License Related Issues and/or contact Global Customer Assistance
  2. In the meantime, while GCA is assisting, you can attempt the following:
    1. Uninstall the 8.11 version from Control Panel
    2. Restore the database from the database backup taken prior the upgrade 
    3. Re-install the same version of App Control prior to the upgrade

Additional Information