Console Inaccessible with Demo Expired Message after 8.11 Server Upgrade
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Console Inaccessible with Demo Expired Message after 8.11 Server Upgrade

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Article ID: 388701

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Updated On:

Products

Carbon Black App Control

Issue/Introduction

After upgrading to Server version 8.11.0 the Web Console displays error message similar to:

Your Demo of Carbon Black App Control has expired. Contact Global Customer Assistance to purchase a copy.

Environment

  • App Control Server: 8.11.0

Cause

  • The Server License file was already expired before the upgrade to Server 8.11.0
  • There is an DNS issue resolving the Web Server Address to the correct IP address

Resolution

I. A valid server license is required to resolve the Demo Expired message.

  1. Log in to the Broadcom Support Portal and download your current Server License.
  2. Follow these steps to import the non-expired Server License:
    1. Stop the App Control Server and App Control Reporter services.
    2. Open SQL Server Management Studio as the Carbon Black Service Account.
    3. Open the .lic file in a text editor and copy the content
    4. Update the following SQL query by pasting the license value within the single quotes:
      USE das; EXECUTE dbo.UpdateLicense 'UPDATE VALUE FROM LIC', '0'
    5. Start the App C Server and Reporter services and attempt to access the console again
  3. If the current license is not available for download in the Support portal:
    1. Open a Non-technical Case for License Related Issues and/or contact Global Customer Assistance
    2. In the meantime, while GCA is assisting, you can attempt the following:
      1. Uninstall the 8.11 version from Control Panel
      2. Restore the database from the database backup taken prior the upgrade 
      3. Re-install the same version of App Control prior to the upgrade

II. If getting this error with a valid license, confirm these:

  1. Open IIS Manager and verify that Anonymous Authentication is enabled
  2. Check that the correct Web Server Address is in the database and that it resolves to the IP address of the server for both IPv4 and IPv6
    1. Open SQL Server Management Studio as the Carbon Black Service Account
    2. Run the following query to get the Web Server Address:
      • USE das; SELECT value FROM shepherd_configs (NOLOCK) WHERE name like 'WebServerAddress'
    3. Verify that the Web Server Address matches the expected App Control Server name
    4. If the name does not match, update it with this query, e.g.
      • USE das;EXEC dbo.updateshepherdconfig @name = 'WebServerAddress', @value = 'APPCServer.example.com';
    5. Add entries in the HOSTS file for the Web Server Address to resolve to the Local IPs of the server
        1. Open Notepad as Admin > File > Open > C:\Windows\System32\drivers\etc\hosts
        2. Add the following lines at the bottom:
          • 127.0.0.1  AppCServer.example.com
            ::1        AppCServer.example.com
          • If the HOSTS file cannot be modified, make sure that the DNS resolves the Web Server Address name to the external IP address of the AppC server for both IPv4 and IPv6 
        1. Validate the settings by pinging the Web Server Address:
          • ping -4  AppCServer.example.com
            ping -6  AppCServer.example.com

Additional Information

  • If any issues are encountered while downloading or locating the Server License:
  • If getting this error with a valid license, confirm that the IIS setting Anonymous Authentication is enabled