VMware vCenter Server 7.x VMware vCenter Server 8.x
Cause
Before starting the remediation, VUM disables 'vim.ManagedEntity.destroy' method which will make sure that the hosts are not removed from the inventory while the remediation is in progress. After that, it creates a task to activate the destroy method once the remediation completes.
Here, VUM is successfully doing the first half of the task but failing at the 2nd step.
VUM is ignoring the above error and going ahead with the remediation. As the task to enable 'vim.ManagedEntity.destroy' method is not added to DB, VUM doesnt enable it after remediation succeeds/fails.
Resolution
The issue can be resolved by using one of the following methods:
Create a new cluster and move the host to the new cluster
Move the host to the datacenter and using PowerCLI command to remove the host