"Invalid Database Password for root to install" error when installing DXNetops Portal from scratch on a new system
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"Invalid Database Password for root to install" error when installing DXNetops Portal from scratch on a new system

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Article ID: 388668

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Updated On:

Products

Network Observability

Issue/Introduction

While installing DX NetOps Portal from scratch on a new system, the install fails with the following:

The current DX NetOps Portal is already using the same version you are about
to install.

Installed version: 24.3.4.6
Product version: 24.3.4.6

Do you want to continue?

Click Yes to upgrade the installation.
Click No to exit the Setup program.

Warning: Be sure to perform a database backup before running the installer to
avoid possible data loss during an upgrade. The procedures are documented in
the Installation Guide.

  ->1- Yes
    2- No

ENTER THE NUMBER OF THE DESIRED CHOICE, OR PRESS <ENTER> TO ACCEPT THE
   DEFAULT: 1

 

===============================================================================
Invalid Database Password (root)
--------------------------------

The provided database password is invalid for the root user, please try again.

PRESS <ENTER> TO CONTINUE:

Environment

Version: Any
Component: Portal Installation

Cause

There was a previous install that either failed or was aborted/canceled before it finished.

Resolution

Uninstall Portal using the instructions in the "Uninstall NetOps Portal" section of the documentation. Then run the install.

Additional Information

The uninstall may fail. If so, do the following:

  • Remove the following two files:
    • /var/.com.zerog.registry.xml
    • /etc/my.cnf
  • Remove the entire /opt/CA directory and all the files contained within. If you installed in a different directory, remove that directory and all the files contained within.
  • Run the install