Configuring ESXi 8 Stateless Image Caching Fails with Error "Volume '<volume_UUID>' cannot be unmounted. Reason: Busy"
search cancel

Configuring ESXi 8 Stateless Image Caching Fails with Error "Volume '<volume_UUID>' cannot be unmounted. Reason: Busy"

book

Article ID: 388580

calendar_today

Updated On:

Products

VMware vSphere ESXi

Issue/Introduction

When attempting to configure ESXi 8 Stateless Image Caching, the process fails with the following error:
volume '<Vol_UUID>' cannot be unmounted. Reason: Busy

Log Details

/var/run/syslog.log

YYYY-MM-DDTHH:MM:SS In(14) hostprofile[2101322]: opID=MainThread: /sbin/applyHostProfile sending boot msg to console: Applying Host Profile task list...Error^@
YYYY-MM-DDTHH:MM:SS Er(11) hostprofile[2101322]: opID=MainThread: while applying tasks: (vmodl.fault.SystemError) {
...
YYYY-MM-DDTHH:MM:SS Er(11)[+] hostprofile[2101322]: key = 'error',
YYYY-MM-DDTHH:MM:SS Er(11)[+] hostprofile[2101322]: value = '("Errors: \nVolume '<volume_UUID>' cannot be unmounted. Reason: Busy\n", b'')'
...
YYYY-MM-DDTHH:MM:SS Er(11)[+] hostprofile[2101322]: message = 'Error: ("Errors: \nVolume '<volume_UUID>' cannot be unmounted. Reason: Busy\n", b'').'

 

/var/log/vmkernel.log

YYYY-MM-DDTHH:MM:SS Wa(180) vmkwarning: cpu105:2101322)WARNING: VC: 2364: unmounting opened volume ('661f2338-c5f#####-####-1423f2331c60' 'OSDATA-<volume_UUID>') with ref 3 is not allowed.
YYYY-MM-DDTHH:MM:SS In(182) vmkernel: cpu105:2101322)FSS: 9794: File fdmDump-##.log, fhID: 1511564, is opened by world: 000002101147 - fdm
YYYY-MM-DDTHH:MM:SS In(182) vmkernel: cpu105:2101322)VC: 2635: Unmount volume f533 28 2 ######## ######### 23147570 601c33f2 4 1 0 0 0 0 0 : Busy

Environment

vSphere ESXi 8.0.2
vSphere ESXi 8.0.3

Cause

  1. FDM Locking Mechanism: Starting from vCenter 8.0.2, FDM (Fault Domain Manager) starts on the ESXi host and locks the log file /var/run/log/fdmDump-*log, preventing unmounting of the OSData volume.

  2. OSData Partition in Use: The OSData partition is actively used, preventing unmounting.

  3. Hardcoded Log Path: The log file location is hardcoded to a specific partition, which contributes to the issue.

Resolution

To resolve this issue, please patch the ESXi hosts to vSphere ESXi 8.0 Update 3e Build 24674464.