From Source vCenter the VM having replication error appears with below alarm,
A replication error occurred at the vSphere Replication Server for replication '###-####-#####'. Details: 'No connection to VR Server for virtual machine ###-####-##### on host #####-###-#####-##.#########-##.##############.##### in cluster #####-###-##-## in #####-###-##: Not responding'./var/run/log/vmkernel.log on the source host reports the below error:####-##-##T##:##:##.270Z Wa(180) vmkwarning: cpu81:8649127) WARNING: Hbr: 571: Connection failed to ###.###.###.### (groupID=GID-cd6ff665-6d2643d-8b53-b867f7cd9af1) : Timeout####-##-##T##:##:##.7272 cpu26:3155154) WARNING: Hbr: 5093: Failed to establish connection to [##.##.##.##]:31031 (groupID=GID-98303ab4-XXXX-XXXX-XXXX-55e9XXXXX3e): Timeout
vSphere Replication version 8.x
vSphere Replication version 9.x
The required ports (31031 or 902 ) is blocked between the source host, and the target vSphere Replication Server.
Network checks and "netcat" commands indicate blocked ports:
[root@ESXiXX:~] nc -zv 10.X.X.X 31031nc: connect to 10.X.X.X port 31031 (tcp) failed: Connection timed out
[root@ESXiXX:~] curl -v telnet://ESX_IP:902
* Trying ##.###.##.##:902...
* connect to ##.###.##.## port 902 from ##.###.##.## port 48024 failed: Connection timed out
* Failed to connect to ##.###.##.## port 902 after 129729 ms: Couldn't connect to server
* curl: (28) Failed to connect to ##.###.##.## port 902 after 129729 ms: Couldn't connect to server
Please ensure that the necessary ports 31031 and 902 are opened between (not blocked ) the Source ESXi host and the Target vSphere replication for proper communication.
Opening port 31031 will enable the necessary communication for the vSphere Replication appliance, allowing the configuration process to proceed successfully. Verifying network settings ensures that all prerequisites are met preventing similar issues in the future.