Unable to deploy new cluster from TMC due to OS version drop-down fields do not have any values
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Unable to deploy new cluster from TMC due to OS version drop-down fields do not have any values

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Article ID: 388542

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Updated On:

Products

Tanzu Kubernetes Runtime vSphere with Tanzu Tanzu Mission Control

Issue/Introduction

  • Users are unable to deploy new clusters from TMC on vSphere with Tanzu Supervisor.
  • When attempting to deploy a new cluster, upon selecting the OS version field, the drop-down provides no values
  • When checking the Management Cluster in TMC Administration, under "Agent and extensions health, the "vsphere-resource-retriever" agent shows a red circle.
  • When checking the vsphere-resource-retriever pod from the Supervisor cluster node, the pod shows in ImagePullBackOff status



  • Describing the pod will show the image attempting to pull from extensions.aws-usw2.tmc.cloud.vmware.com:

 

Environment

TMC managed Supervisor clusters might be impacted by this.

Cause

The image repos for TMC were migrated starting January 31st according to the this KB. This led to some images not being updated.

Resolution

Please contact Broadcom support if you see the incorrect image registry listed for the vsphere-resource-retreiver pod so the TMC team can correct this.

 

If an immediate workaround is required, edit the vsphere-resource-retriever deployment in the Supervisor cluster to manually point the image base URL to: extensions.stacks.whitesand.tmc.tanzu.broadcom.com

Example:

imageID: extensions.aws-usw2.tmc.cloud.vmware.com/extensions/resource-retriever/server@sha256:43b56e8f5876c130e21e097593b8e944395dad1176928e3e5274af111838d108

Becomes:

imageID: extensions.stacks.whitesand.tmc.tanzu.broadcom.com/extensions/resource-retriever/server@sha256:43b56e8f5876c130e21e097593b8e944395dad1176928e3e5274af111838d108