vSphere Client and Site Recovery UI reports error : "Cannot establish a TCP connection to server at 'x.x.x.x:443' "
search cancel

vSphere Client and Site Recovery UI reports error : "Cannot establish a TCP connection to server at 'x.x.x.x:443' "

book

Article ID: 388473

calendar_today

Updated On:

Products

VMware Live Recovery

Issue/Introduction

  • vSphere Client and Site Recovery UI both reports following error in 'Recent Tasks' section :

    Cannot establish a TCP connection to server at '10.xx.xx.121:443'. Details: 'https://10.xx.xx.121:443/hbr invocation failed with "org.apache.http.conn.ConnectTimeoutException: Connect to 10.xx.xx.121:443 [/10.xx.xx.121] failed: Connect timed out"'.
  • The task gets logged every 1-2 minutes and keeps failing.

Note : If vmk0 is enabled for vSphere Replication along with another VMK that is dedicated for vSphere Replication, both enabled with vSphere Replication traffic, vmk0 IP address is seen in the above stated error.

Environment

vSphere Replication 8.x

vSphere Replication 9.x

Cause

  • Every ESXi host in vCenter inventory under which the VR server is deployed would be probed by VR server over port 443 to ensure it is available for the VM replication.

  • For any reason, if the ESXi host is not reachable, the HMS service of VR server would report this error.

Resolution

  • Validate the connectivity from VR server to ESXI host by running following command in its SSH session:
    # curl -v telnet://<vSphere_Replication_Enabled_vmk_IP>:44
  • If the curl command failed to connect, it means that then the connectivity on port 443 is blocked by either the ESXi internal firewall or an external firewall.
  • To resolve the issue, the connectivity on port 443 between the the vSphere Replication server and the ESXi host has to be allowed.