vSphere Client and Site Recovery UI reports error : "Cannot establish a TCP connection to server at 'x.x.x.x:443' "
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Article ID: 388473
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Updated On:
Products
VMware Live Recovery
Issue/Introduction
Symptoms
vSphere Client and Site Recovery UI both reports following error in 'Recent Tasks' section :
"Cannot establish a TCP connection to server at '10.xx.xx.121:443'. Details: 'https://10.xx.xx.121:443/hbr invocation failed with "org.apache.http.conn.ConnectTimeoutException: Connect to 10.xx.xx.121:443 [/10.xx.xx.121] failed: Connect timed out"'.
The task gets logged every 1-2 minutes and keeps failing.
Environment
vSphere Replication 8.x
vSphere Replication 9.x
Cause
Every ESXi host in vCenter inventory under which the VR server is deployed would be probed by VR server over port 443 to ensure it is available for the VM replication.
For any reason, if the ESXi host is not reachable, the HMS service of VR server would report this error.
Resolution
Validate the connectivity from VR server to ESXI host by running following command in its SSH session:
# curl -v telnet://<x.x.x.x>:443
where x.x.x.x --> is the IP address of the VMkernel adapter (where vSphere Replication traffic is enabled) of ESXi host.
(Note : If by configurational mistake, vmk0 and vmkX (X is separate VMkernel adapter) both enabled with vSphere Replication traffic, vmk0 IP address is seen in the above stated error.
The connection error if seen on running above command would need enabling of port 443 on ESXi internal firewall or external firewall (if any) in the vSphere environment.