VM network adapter unable to be added to a portgroup from host client
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VM network adapter unable to be added to a portgroup from host client

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Article ID: 388373

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Updated On:

Products

VMware vSphere ESXi

Issue/Introduction

  • The issue has been observed in the ESXi host client (web UI), when VMs are using the vSphere Standard Switch (VSS) "VM network" portgroup.
  • Occurs after a VM has been unregistered from a host in vCenter and registered to a standalone host.
  • Unable to assign network settings to network card in the guest OS; IP address, gateway, DNS, and domain fail to be assigned
  • When viewing the summary page of the affected VM, the following error message is displayed:
    "This VM is attached to a network port group VM Network that doesn't exist. Edit this VM and attach it to a different network."
  • The following error message is also seen when attempting to edit the VM's network settings in the ESXi host client:
    "The portgroup for Network adapter 1, network, could not be found. It has been assigned to network2."

Environment

VMware vSphere ESXi

Cause

The VM network adapter is retaining cached information, preventing modification.

Resolution

Remove the VM's current network adapter and recreate it. See Add a Network Adapter to a Virtual Machine in the VMware Host Client for more information.

Once the adapter has been recreated, the network settings should appear normally in the VM summary page of the ESXi host web client.