PAM RSA Integration stopped working after upgrade to 4.2.1
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PAM RSA Integration stopped working after upgrade to 4.2.1

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Article ID: 388366

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Updated On:

Products

CA Privileged Access Manager (PAM)

Issue/Introduction

PAM was upgraded to 4.2.1 and RSA logins are now failing. All the necessary steps from the Configure PAM to Support RSA SecurID Authentication documentation page were followed to convert to Rest API, but the issue is still occurring.

Environment

The issue will only occur when upgrading directly to Privileged Access Manager 4.2.1 from 4.1.0-4.1.4.

Cause

When upgrading from a pre-4.1.5 release, the configuration file used for authentication gets updated to use the REST API for RSA authentication. There is an issue with the 4.2.1 upgrade script which caused the configuration file to not be updated, so PAM continued to use the legacy RSA authentication client.

Resolution

The issue is resolved as DE626921 in the 4.2.2 release, upgrade to 4.2.2 or newer.

If an upgrade is not possible at this time, apply the 4.2.1.02 hotfix. The hotfix can be downloaded from the PAM Solutions & Patches page.