LDAP users can't login after upgrading from 22.2.10 to 24.3.5 in Portal
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LDAP users can't login after upgrading from 22.2.10 to 24.3.5 in Portal

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Article ID: 388208

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Updated On:

Products

Network Observability CA Performance Management

Issue/Introduction

After successful upgrade of Performance Management the LDAP users can't login into Portal. Local users can successfully log in.

The following error is displayed in the browser: (URL: https://<Portal_hostname>:8382/sso/sign-in/process.jsp)

This page isn't working

500. That's an error.

Environment

Performance Management 24.3.5

Cause

The error is searchTagAttribute is null from asking ldap results for memberOf.

 

The following error was found in the /opt/CA/PerformanceCenter/sso/logs/SSOService.log file:

WARN  | qtp888816201-42          | 2025-02-12 17:15:18,901 | org.eclipse.jetty.server.HttpChannel                             
      | /sso/sign-in-process.jsp
org.apache.jasper.JasperException: An exception occurred processing [/sign-in-process.jsp] at line [205]

202: else
203: {
204:     // Validate the user
205:     userId = authenticationUtility.authenticateUser(session, singleSignOnWSSoap, username, password);
206:     // Check the result
207:     if (userId <= 0)
208:     {

Caused by: java.lang.NullPointerException: Cannot invoke "javax.naming.directory.Attribute.getAll()" because "searchTagAttribute" is null

The same error is displayed when running the SsoConfig - Test LDAP

Resolution

Remove the LDAPGroups entry via SsoConfig.

<LDAPGroups><Group searchTag="memberOf" searchString="CN=XXX_All Employees,CN=Users,DC=company,DC=local" user="{sAMAccountName}" passwd="" userClone="admin"/></LDAPGroups> 

 

Choose 1. LDAP Authentication

Choose 1. Remote Value

Choose 10. Group

Enter r to reset the value

Then rerun 5. Test LDAP