Diagnostic Tab in Aria Operations is not seen when authenticated via vIDM Authsource.
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Diagnostic Tab in Aria Operations is not seen when authenticated via vIDM Authsource.

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Article ID: 388166

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Updated On:

Products

VMware Aria Suite

Issue/Introduction

The Diagnostic Tab in Aria Operations is not visible when authenticated via vIDM Authsource.

However, it is accessible when logging in with a local user or an AD domain account.

Environment

Aria Operations 8.18.x

Identity Manager 3.3.x

Cause

The problem arises from the switch between the old and new UIs.

This issue goes beyond the addition of the diagnostics menu, it involves a complete change of the UI structure. In version 8.18, the correct login URL should be /ui/login.action?vcf=1 (with vcf=1 included). However, the 'Identity Manager' is still using the older '/ui' URL, which logs users into the old UI.
In the old UI, a redirection to vIDM would dynamically generate a one-time WebCode in the URL's query string, enabling automatic login. This workaround continued to function until the introduction of the VCF UI.

Resolution

This is a known issue with Aria Operations.

This issue will be resolved in the next major release, where an additional feature implementation will address the vIDM auto-login process.

Workaround:

  • Log out of the Aria Operations UI.
  • Log back in as Admin (Local User) to make the Diagnostic Tab visible.
  • Once verified, log back in as a 'regular/domain vIDM user'.

Note: 

  • Logging out and back in as a Local Admin allows the system to refresh and display the Diagnostic Tab correctly.
  • Once visible, the vIDM user sees the VCF UI as expected.