VROPS admin Password Disconnected in SDDC Manager - VCF 4.x
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VROPS admin Password Disconnected in SDDC Manager - VCF 4.x

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Article ID: 388159

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Updated On:

Products

VMware SDDC Manager

Issue/Introduction

In some deployments of vRealize Operations 8, there may be a load balancing FQDN with a single admin account, and 3 VROPS nodes in a cluster each with their own root account. The load balancing admin account is normally changed by running commands on the primary VROPS node in the cluster.

This article provides guidance for resetting the admin account password and remediating the password in SDDC Manager, when the primary VROPS node is unknown, and remediation with the last known password fails.

Environment

VCF 4.5.1

vRealize Operations 8.6.4

Cause

admin account on VROPS was changed or expired out-of-band from SDDC password management.

Resolution

1) SSH into the SDDC Manager as the vcf user. su to the root user.

2) Run lookup_passwordsfor VROPS. Note the admin password value.

3) Run systemctl stop operationsmanager

4) SSH into each VROPS node (01, 02, and 03) as the respective root user.

5) Run echo -n "" > /etc/security/opasswd on each node. Confirm there is nothing returned when running cat /etc/security/opasswd

6) On each VROPS node, run $VMWARE_PYTHON_BIN $VCOPS_BASE/../vmware-vcopssuite/utilities/sliceConfiguration/bin/vcopsSetAdminPassword.py --reset    and provide the password value from lookup_passwords when prompted.

7) On the SDDC Manager SSH session, run systemctl start operationsmanager

8) Open the SDDC Manager web client and go to the Password Management screen. It may take a few minutes for operationsmanager to fully start and the passwords to load.

9) For the VROPS admin password, click the triple dot icon and select "Remediate Password". Provide the value that the admin password was set to.