The CSV downloaded from Devices > Managed Devices contains more columns than headers
search cancel

The CSV downloaded from Devices > Managed Devices contains more columns than headers

book

Article ID: 388146

calendar_today

Updated On:

Products

Endpoint Security Complete

Issue/Introduction

When opening a CSV downloaded from the Symantec Endpoint Security Complete (SESC) Console > Devices > Manged Devices with Microsoft Excel, there are more columns than headers.

Environment

SESC

Cause

An internal change caused the export to be formatted in an unexpected way.

Resolution

The Broadcom Engineering Team has fixed this issue in SESC February 2025 refresh update .

If immediate relief is required, please use one of the following workarounds.

  1. Open the file in Google Sheets or using LibreOffice - This is the easiest workaround. (note: saving the files after opening should fix them so they can be opened in MS Excel)
  2. Reformat the file:
    1. Open the CSV in a text editor
    2. On the first row only replace the , with ;
    3. On all other rows replace the string ", with ";
    4. Save the file
    5. Open Excel
    6. Create a new Workbook
    7. Navigate to Data > Get External Data > From Text
    8. Select the modified CSV file and click "Open"
    9. Ensure "Delimited" is selected and click "Next"
    10. Under "Delimiters" select only "Semicolon" and click "Finish", then click "Ok"