Old alarms are being sent out by Spectrum Alarm Notifier
search cancel

Old alarms are being sent out by Spectrum Alarm Notifier

book

Article ID: 387993

calendar_today

Updated On:

Products

Network Observability Spectrum

Issue/Introduction

There were some network issues in which the primary SpectroSERVER could not contact the secondary SpectroSERVER.  Both SpectroSERVERs have Alarm Notifier running on them.  When the disconnect occurred, the secondary Notifier sent out old alarms.

Cause

Alarm table corruption on the secondary SS.  Most likely caused by a scanning tool.

Resolution

Remove and reload the SpectroSERVER database on the secondary SS.

Transfer the latest SSdb backup file to the secondary.

Unzip it and place it in the $SPECROOT/SS-DB-Backup directory

Stop the SpectroSERVER - from $SPECROOT/bin:   ./stopSS.pl

Stop processd as root:  systemctl stop processd

Remove the *.db and *.ix files in $SPECROOT/SS:   rm *.db *.ix

  -- This step is very important as this is what allows Spectrum to rebuild the alarm table

Restart processd as root: systemctl start processd

As the spectrum install owner, reload the SSdb from the $SPECROOT/SS directory:   ../SS-Tools/SSdbload -il ../SS-DB-Backup/db_backup.SSdb

Start the SS  from $SPECROOT/bin:   ./startSS.pl