The Aria/VCF Operations dashboard in Aria /VCF Operations for Logs displays as empty or shows "No results"
search cancel

The Aria/VCF Operations dashboard in Aria /VCF Operations for Logs displays as empty or shows "No results"

book

Article ID: 387954

calendar_today

Updated On:

Products

VCF Operations/Automation (formerly VMware Aria Suite) VCF Operations

Issue/Introduction

  • Launch Aria/VCF Operations for Logs UI > Navigate to Dashboards > Select any dashboard under VMware Aria Operations/VCF Operations (as shown in below screenshot) displays "No results" or empty data.

    • In Aria Operations for Logs 8.x you see:

 

    • In VCF Operations for Logs 9.x you see:



Environment

Aria Operations 8.x
Aria Operations for Logs 8.x
VCF Operations 9.x 
VCF Operations for Logs 9.x

Cause

This issue occurs when the log forwarding/log collection is not configured with the CFAPI protocol from Aria/VCF Operations to Aria/VCF Operations for Logs. The CFAPI protocol provides additional information used by the Aria/VCF Operations Content Pack. The CFAPI protocol is mandatory for Aria/VCF Operations content pack dashboards.

Resolution

  • Follow the below steps to configure log forwarding from Aria Operations 8.x to Aria Operations for Logs 8.x:

    1. Launch the Aria Operations Product UI instance.
    2. Navigate to Administration > Control Panel > Log Forwarding.
    3. Select the checkboxes "Output logs to external log server" and "Forwarded Logs" as shown in below snippet
    4. Under Forwarded Logs, select the appropriate checkboxes that are intended to be forwarded to the Aria Logs Server.
    5. Select Operations for Logs Servers – Other.
    6. Enter the FQDN or IP address of VMware Aria Operations for Logs in the Host field.
    7. Set the Protocol to cfapi.
    8. Set the Port to 9000. If Use SSL is checked, set it to 9543.
    9. (Optional) Enter the path to the certificate authority file (not mandatory).
    10. Enter the Cluster Name.
    11. Click on Apply changes.




  • In VCF 9, the Log Forwarding menu is deprecated. Follow the below steps to configure log collection from VCF Operations 9.x to VCF Operations for Logs 9.x:

    1. Launch the VCF Operations Product UI instance.
    2. Navigate to Infrastructure Operations > Configurations > Log Collection and edit the VCF Operations instance.
    3. Under the 'Override Advanced configuration', select 'CFAPI' as the protocol(as shown in screenshot below) and save.
    4. Launch the VCF Operations for Logs UI > Configuration > SSL, check if "Require SSL Connection" is enabled. If enabled, select the 'Activate' option next to SSL in VCF Operations(as shown in screenshot below) and save.

      VCF Operations:




      VCF Operations for Logs:

Additional Information