ConnectAll upgrade by connectall user fails with error Insufficient disk space
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ConnectAll upgrade by connectall user fails with error Insufficient disk space

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Article ID: 387831

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Updated On:

Products

ConnectALL

Issue/Introduction

While upgrading ConnectAll as connectall user we are getting below error

if you have chosen Upgrade, the installer will issue stop commands for
ValueOps ConnectALL processes, if they are detected to be running.
Checking Disk Space
Insufficient disk space - ConnectALL needs at least 4GB of free space to successfully complete the installation. Quitting installation.

 

We checked the available disk space with command df -pHt and it seems to have more than 4GB space available with install directory mount but still installer throws the above error.

Environment

ConnectAll: 3.6.0 or higher

OS: RHEL8

 

Cause

  • Check response.varfile in the ConnectAll install directory at path <INSTALL_DIR>./install4j/response.varfile and make sure the variable CONNECTALL_HOME is pointing to correct ConnectAll home directory
  •  Find presence of other install4j directories on the system with command find / -name "install4j"
  • Check prefs.xml file at path /<username>/.java/.userPrefs/com/install4j/installations/prefs.xml of the username(most likely root) who installed the ConnectAll and validate it is pointing to correct install directory

Issue seems to be with permission related to username connectall in RHEL8 SELinux configuration, resulting in above error. 

 

Resolution

Run the upgrade as root user who installed the ConnectAll