UIM data_engine 23.4 is down and keep restarting
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UIM data_engine 23.4 is down and keep restarting

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Article ID: 387817

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Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM) CA Unified Infrastructure Management On-Premise (Nimsoft / UIM) CA Unified Infrastructure Management SaaS (Nimsoft / UIM)

Issue/Introduction

Post-reboot of DB server, data_engine was stopping/disconnecting constantly/could not keep the same PID.

Error in data_engine.log->

..."waiting for 1 thread to release resources" 

repeated in the data_engine log.

Environment

  • DX UIM 23.4 CU1
  • hub/robot ###.##.##.##
  • robot version 23.4.2.1
  • data_engine 23.4.0
  • IM version 23.4.1
  • DB: <example_db_server_name>, <IP_ADDRESS>
  • MS SQL Server 2019 64-bit Enterprise

Provider = SQLNCLI11

Please note that this provider is out of support and deprecated by Microsoft so it should be changed to use MSOLEDBSQL.

Please refer to: DX UIM 20.4/23.4 - which database driver is supported for MS SQL Server database on Windows

Cause

  • MS SQL Server Transaction log full

Resolution

The data_engine was still green and had a port but the PID kept changing which indicates its constantly restarting/disconnecting.

Concerning DB Best practices especially as it pertains to ths full transaction log event in thie scenario, please refer to:

DX UIM (Nimsoft) Database Best Practices for MS SQL Server

Once the customer's DBA joined the call, they saw the DATABASE LOCK/UNLOCK entries and checked the UIM DB on the backend.

The customer's DBA found that the SQL Server transacton log was full then remedied the situation and the data_engine probe was cold started (Deactivate-Activate), re-fetched the correct connection string, and then began inserting data and finally kept the same PID after the DBA removed the DB from the 'Always On' Group (AG).