Workflow jobs randomly stop processing
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Workflow jobs randomly stop processing

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Article ID: 387650

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Updated On:

Products

CA Identity Manager

Issue/Introduction

Workflow jobs randomly stop processing without advancing to the next node.

There may be no errors, the issue may occur for any job type, and the workflow may stop processing on any node.

In the Workpoint Designer, the job(s) appear to be inadvertently stopped on a node.

Cause

A large number of rows, duplicate entries, NULL states, or other problems in the WP_JOB_MONITOR  table.

Resolution

After shutting down IM, use the following SQL command to clear the table:


Run the DELETE command on table WP_JOB_MONITOR WHERE PROC_REF IS NULL;


Additionally,

Remove the duplicate files/folders inside the deployed iam_im.ear folder, for example, in ../standalone/deployments/iam_im.ear.

If removing the backup files/folders does not resolve the issue then,

Take a back up of WP_JOB_MONITOR table (it is not needed but just in case). After shutting down IM, use the following SQL command to clear the table:

Run the DELETE command on table WP_JOB_MONITOR WHERE PROC_REF IS NULL;

Which will clear nearly all the rows in the table. Start the IM and run the tests to make sure everything is working fine.

Clearing the rows as above may need to be done periodically in environments with heavy workflow activity.

PROC_REF IS NULL and  REFERENCE=‘lcheck’ has same entries when doing count


A manual restart of the jobs needs to be done from the Workflow Designer in order for the jobs to continue.