Token Issuer not auto-populated in Mutli Factor Authentication Chain authentication scheme
search cancel

Token Issuer not auto-populated in Mutli Factor Authentication Chain authentication scheme

book

Article ID: 387605

calendar_today

Updated On:

Products

SITEMINDER VIP Authentication Hub

Issue/Introduction

When selecting the VIP Authentication Hub Authentication Instance under the Secondary Authentication Scheme, the Token Issuer in the ID Token Hint Generation Setup section is typically auto-populated. However, in this case, the auto-population is not functioning, and the Token Issuer is left unpopulated.

The following error was observed in the Admin UI logs:

2025-02-04 15:22:56,751 [ERROR] com.ca.siteminder.webadmin.tabs.BaseAuthSchemeGeneralTabPage [] - getApplicationId, ApplicationId: f6ab92a0-75fd-493a-b98c-59e8ffffa4a6

2025-02-04 15:22:56,751 [ERROR] com.ca.siteminder.webadmin.tabs.BaseAuthSchemeGeneralTabPage [] - Fetching the VIP Authentication Provider Certificates for Siteminder

2025-02-04 15:22:56,751 [ERROR] com.ca.siteminder.webadmin.tabs.BaseAuthSchemeGeneralTabPage [] - getAuthHubCertificates, tokenEndpoint: https://ssp-xxx.xxx.xxx.xxx.net/default/oauth2/v1/token

2025-02-04 15:22:56,878 [ERROR] com.ca.siteminder.webadmin.tabs.BaseAuthSchemeGeneralTabPage [] - Fetching the CertAlias of VIP Authentication Application type  = null, Provider Name = VIP_AHfor Siteminder

 

Environment

SiteMinder 12.8.x
VIP Authentication Hub 3.2.x, 3.3.x

Cause

The credentials were not loaded up by Admin UI

Resolution

The following steps can be done to workaround this problem.

Open the VIP Authentication Hub Provider and do the following steps on the Provider tab
   1. Click the [Modify] button
   2. Click the [Test Connection] button and make sure the test is successful
   3. Click the [Save] button