Failed to export Shared Content in Aria Operations for Logs
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Failed to export Shared Content in Aria Operations for Logs

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Article ID: 387590

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Updated On:

Products

VMware Aria Suite

Issue/Introduction

When going to Content Packs > Shared Content and trying to export the listed the Dashboards, the process resulted in a "Failed" state with no further information.

Environment

Aria Operations for Logs 8.18.x

Cause

Tomcat server's default maxPost limit is 2MB, if not defined explicitly.

If the export content is exceeding 2MB, it will result in "Failed" state.

Resolution

1. SSH into the primary node as root.

2. Make a backup file for tomcat server.xml:

    cd /usr/lib/loginsight/application/etc/3rd_config/

    cp server.xml server.xml.bkp

3. While in the above directory, edit the tomcat server.xml by running the following command:

    vi server.xml

4. Locate the lines starts with  <Connector port=, then add the maxPostSize="5242880" in both of the lines. See screenshot below from a testing lab environment:

5. Restart loginsight service:

    service loginsight restart

6. Then try to export the content by going to this primary node's UI. If it works fine, repeat the steps on all other nodes.

7. If it does not work, increase the maxPostSize to 10 MB or as needed. Then repeat the steps on all other nodes.

 

Important note:

1. The default maxPost limit will not change in the feature release as 2MB is common use. The above is a workaround for users who have exceed the limit and encounter the issue.

2. In case of upgrade, the changes made will revert, users will need to perform the above steps again if needed.