Workspace Unavailable
search cancel

Workspace Unavailable

book

Article ID: 387573

calendar_today

Updated On:

Products

CA Harvest Software Change Manager

Issue/Introduction

When end users try to open Workbench (via Citrix) they are seeing Workspace Unavailable message

We upgraded to 14.5 lately. Users didn't encounter this issue before.

Environment

CA Harvest Software Change Manager 14.5 

Cause

This behavior is consistent with the old release as well. However, in the old release, users had the option to run Workbench as a normal user, allowing it to open in their own user profile workspace. If Workbench was run as an administrator, it would attempt to open in the administrator’s user profile workspace and this current customer issue occurs there as well in this scenario.

In the new release, users no longer have the option to run Workbench normally and must run it as an administrator. As a result, the workspace defaults to the administrator profile, leading to this issue.

Resolution

If you want Workbench to always open a workspace based on the logged-in user, ensure that when a popup appears select the checkbox as shown below:
“Use this as the default and do not ask again”

And select the appropriate workspace for the specific profile.

This is a onetime activity and the user will not see the popup message again.

Another workaround would be:

We can also achieve the same of setting the explicit Workspace Path using the -data argument in shortcut.
Right-click on the Workbench shortcut and select Properties.
In the Target field, append the -data option with the workspace path:
 "C:\Program Files\CA\SCM\workbench.exe" -data "@user.home/.cascm/workspace"

Click Apply and then OK.
Launch Workbench using this shortcut.
Note:  for this method, there is a limitation that Workbench will always open the specified workspace, preventing users from switching to another workspace at startup

Additional Information

The second workaround resolution also works for the case when the workspace is not created.