ESXi host crashes with PSOD (purple screen of death) with Usage error in dlmalloc
search cancel

ESXi host crashes with PSOD (purple screen of death) with Usage error in dlmalloc

book

Article ID: 387569

calendar_today

Updated On:

Products

VMware vSphere ESXi 7.0 VMware vSphere ESXi 8.0

Issue/Introduction

  • ESXi host crashes with a PSOD with "PANIC bora/vmkernel/main/dlmalloc.c:4944 - Usage error in dlmalloc".
  • This issue observed in ESXi hosts with Dell RecoverPoint installed.
  • The PSOD backtrace looks like below.
PanicvPanicInt@vmkernel#nover+0x327 stack: 0x453ad159b468, 0x0, 0x42000f6ff107, 0x432e6fe46100, 0x453ad159b390
Panic_NoSave@vmkernel#nover+0x4d stack: 0x453ad159b4c0, 0x453ad159b480, 0x0, 0x42000fca9a78, 0x1350
DLM_free@vmkernel#nover+0x242 stack: 0x432e6fe461b0, 0x42000f743c1e, 0x431692401297, 0x7ad, 0x0
Heap_Free@vmkernel#nover+0xba stack: 0x0, 0x432e6fe461b0, 0x45c00e8dd0b0, 0x453aa459f000, 0x824
UserSemaFDClose@vmkernel#nover+0x42 stack: 0x0, 0x42000fab982c, 0x431692401220, 0x431692401284, 0x0
UserObj_ReleaseWithoutCartel@vmkernel#nover+0x10 stack: 0x0, 0x42000fabd6c1, 0x453ad159b5e8, 0x45c00e8dd0b0, 0x0
UserObj_VsiFdGet@vmkernel#nover+0xd1 stack: 0x0, 0x453ad159b5e8, 0x431692401220, 0x42000fad32d2, 0x3000000000
UserVsi_Cartel_Fd_FdsGet@vmkernel#nover+0xb2 stack: 0x453aa459f000, 0x432fbf802010, 0x42000fad3220, 0x0, 0x520
VSI_GetInfo@vmkernel#nover+0x28f stack: 0x41ffcf647960, 0x0, 0x800000000, 0x824, 0x6610cec7d0
UW64VMKSyscallUnpackVSI_Get@vmkernel#nover+0x114 stack: 0x453a2c81f140, 0x453ad159b6a0, 0x520, 0x6610cec701, 0xf4ddafaac2d165
User_UWVMK64SyscallHandler@vmkernel#nover+0x183 stack: 0x1bf4ddafaac2d165, 0x6610cec7d0, 0x0, 0x0, 0x3b7306cbb70
SyscallUWVMK64@vmkernel#nover+0x90 stack: 0x0, 0xbad000e, 0x6651563c70, 0x1bf4ddafaac2d165, 0x0
ESC[45mESC[33;1mVMware ESXi 7.0.3 [Releasebuild-23794027 x86_64]ESC[0mPANIC bora/vmkernel/main/dlmalloc.c:4944 - Usage error in dlmalloc

Environment

VMware ESXi 7.x
VMware ESXi 8.x

Cause

The cause of the PSOD is a race condition between VSI file descriptor cleanup and the handling of userSemaFD objects.

Resolution

The issue is addressed in ESX 8.0 P05. 

Workaround:

To remediate the issue, consider uninstalling the VIB shipped with lsof utility after discussing with Dell RecoverPoint team.