sdgtw probe is not creating events in ServiceNow
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sdgtw probe is not creating events in ServiceNow

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Article ID: 387546

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Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM)

Issue/Introduction

After working to configure the sdgtw probe, events are not being created in ServiceNow.  In the sdgtw logs, we see the following:

[Thread-93, sdgtw] checkConnection: Got NimException connecting to queue ticket: (4) not found, Received status (4) on response (for sendRcv) for cmd = 'subscribe' name = 'null'

 

Environment

  • UIM 23.4
  • sdgtw 2.35

Cause

A hub queue named 'tickets' has been created.  This is the default name for the queue.

The sdgtw probe config shows the following key: queue_name = ticket

With this mismatch, the probe is showing errors in the log as it can not connect to the configured queue (it doesn't exist). 

Resolution

Change the sdgtw config to indicate the correct queue name in the General Properties as described in the documentation:

Configure General Properties

  • Queue Name: specifies the hub queue that the probe subscribes to receive alarms.
    Default: tickets