Consecutive errors on some monitors were jumping up to 4 and 2
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Consecutive errors on some monitors were jumping up to 4 and 2

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Article ID: 387463

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Updated On:

Products

CA Application Performance Management (APM / Wily / Introscope)

Issue/Introduction

Have noticed that ASM agent metric Consecutive errors on some monitors is jumping up to 4 and 2 at a time. This behavior seems inconsistence when compared the ASM side logs for the monitors.  

Cause

We suspect that ASM streaming API exceptions may be causing the issue where ASM streaming API is sending wrong data to the ASM agent. Due to this the ASM agent may be reporting wrong values to the APM UI.

Resolution

Since, we are on the latest ASM agent which is using the streaming API method to get information from the ASM side, we can stick with current consecutive error behavior for now.

This value represents how many times an error occurred consecutively.

Here are some more detail on this.

The consecutive error is calculated by the ASM Agent, based on the ASM event result code, or probe error/error per interval, not the confirmed error/check error.

Further details are explained in the online guide.

ASM Metrics

Bundle.Properties File

The following properties are added to ASM Agent with Event Stream:

asm.allErrors: Specifies the Errors Per Interval value. Set to true to view all errors else, you view the confirmed errors for Errors Per Interval value. Default: True

asm.obsoleteMetrics: Specifies the Errors Per Interval, Consecutive Errors, and Last Check Status metrics when set to true. Default: True

So it seems to us when asm.allErrors is set to true, which is the default, other errors besides the confirmed errors could also be included.