"Queue 0 of device vmnicX stuck, resetting the device" error causes vmnic to flap on ESXI host
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"Queue 0 of device vmnicX stuck, resetting the device" error causes vmnic to flap on ESXI host

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Article ID: 387420

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Updated On:

Products

VMware vSphere ESXi

Issue/Introduction

  • In the vCenter, on the problematic host, you see an alarm for "Network Uplink Redundancy Lost".

  • In the host's /var/log/vobd.log, we can see the below message reporting link state to be down:
    [netCorrelator] 15037473322098us: [vob.net.vmnic.linkstate.down] vmnic vmnicX linkstate down
  • Around the same time, in the host's /var/log/vmkernel.log, we can see that, the queue of the vmnic got stuck and therefore, the watchdog issued a reset causing the link state to go down:
    cpu33:2097231)WARNING: Uplink: 21014: Queue 0 of device vmnicX stuck, resetting the device
    cpu38:2097388)nmlx4_en: vmnic5: nmlx4_en_UplinkReset - (nmlx4_en_uplink.c:2577) Watchdog process reset the uplink for port: 0x1
  • In some scenarios, the issue will happen after events in the hostd reporting high temprature on the NIC:
    Hostd[2099103]: [Originator@6876 sub=Vimsvc.ha-eventmgr] Event 26461 : Sensor 161 type temperature, Description [Device] Add-in Card 17 AOC_NIC Temp state assert for . Part Name/Number N/A N/A Manufacturer N/A

    Hostd[2099103]: [Originator@6876 sub=Vimsvc.ha-eventmgr] Event 26462 : Hardware Sensor Status: Processor , Memory , Fan , Voltage , Temperature Red, Power , System Board , Battery , Storage , Other
  • Similarly, in some scenarios, the high temprature events will also be reported in the vmkernel logs:
    2026-04-29T06:57:15.261Z In(182) vmkernel: cpu1:2098152)<NMLX_INF> synd 0x10: High temprature
    2026-04-29T06:57:15.319Z In(182) vmkernel: cpu0:2098118)<NMLX_INF> synd 0x10: High temprature

Environment

VMware vSphere ESXi

Cause

As the queue of the vmnic adapter got stuck, the watchdog process reset the uplink. Generally, this is a recoverable state and the link state should be back up in a few seconds.

Resolution

This is a condition that may occur in a VMware vSphere environment, try to resolve the issue following the steps below:

  1. Obtain the network adapter driver name, version and firmware version using the steps detailed in Determining Network/Storage firmware and driver version in ESXi.

  2. From Supported drivers and firmware versions for I/O devices, compare the latest available driver and firmware version with the current version obtained from the above step. If the current version is outdated, kindly update the driver and firmware version to the latest supported.

  3. For driver upgrade, follow the steps from Download and install async drivers in VMware ESXi. For firmware upgrade, engage your hardware vendor.

  4. Even after upgrading the driver and firmware version to the latest, should the issue persist, engage your hardware vendor.