AwE-5123 Email error - Domain contains illegal character
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AwE-5123 Email error - Domain contains illegal character

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Article ID: 387350

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Updated On:

Products

CA Automic Applications Manager (AM)

Issue/Introduction

After logging into the Java Client or during a client session the following RmiServer error may be seen:

ErrorMsg: AwE-5123 Email error
Details: Domain contains illegal character
{mail.smtp.port=25, mail.smtp.writetimeout=180000, mail.smtp.host=smtp.sample.net, mail.smtp.timeout=180000, mail.smtp.connectiontimeout=30000, [email protected]}

Cause

A notification configuration contains an illegal character in recipient email value

Resolution

The error due to a illegal character in a notification setting. The notification is likely triggered from a Job completion. To determine which notification or Job that triggered the notification, a review of the RmiServer<timestamp>.log is required.

With RmiServer debug enabled, review the $AW_HOME/log/RmiServer<timestamp>.log or %AW_HOME%\log\RmiServer<timestamp>.log (Windows OS), covering the time of the error message.

Search for error string "Domain contains illegal character". Once found, the lines leading up to the error should provide the notification object name and the error details should provide the email address value that contains the illegal character.

Below is an example snippet from the RmiServer<timestamp>.log showing the lines printed leading up to and including the error message

12:45:10.800 nfy0: email null  TEST_Notification@[email protected]@email.com Test notification: FINISHED TEST_JOB 11131956.00
12:45:10.800 nfy0: .AwEnvOptions: using default: emailconnectiontimeout = 30
12:45:10.800 nfy0: .AwEnvOptions: emailconnectiontimeout = 30
12:45:10.800 nfy0: .AwEnvOptions: using default: emailtimeout = 180
12:45:10.800 nfy0: .AwEnvOptions: emailtimeout = 180
12:45:10.800 nfy0: .Email: smtpAuth=false; smtpSSL=false
12:45:10.802 nfy0: AwE-5123
12:45:10.802 nfy0: .AxOptions: NoErrorMsgProperties=false
ErrorMsg: AwE-5123 Email error (1/24/25 12:45 PM) 
Details: {mail.smtp.port=25, mail.smtp.writetimeout=180000, mail.smtp.host=smtp.sample.net, mail.smtp.timeout=180000, mail.smtp.connectiontimeout=30000, [email protected]}
jakarta.mail.internet.AddressException: Domain contains illegal character in string ``[email protected]@email.com''
    at jakarta.mail.internet.InternetAddress.checkAddress(InternetAddress.java:1410)
    at jakarta.mail.internet.InternetAddress.parse(InternetAddress.java:1191)
    at jakarta.mail.internet.InternetAddress.parse(InternetAddress.java:728)
    at jakarta.mail.internet.InternetAddress.<init>(InternetAddress.java:95)
    at com.appworx.shared.code.email.Email.A(Email.java:322)
    at com.appworx.server.data.Master.sendEmail(Master.java:479)
    at com.appworx.master.JobStarter.doNotification(JobStarter.java:3139)
    at com.appworx.master.JobStarter$NotificationWorker.doRun(JobStarter.java:3441)
    at com.uc4.be.threading.AbstractWorker.run(AbstractWorker.java:367)
    at java.lang.Thread.run(Unknown Source)

In the above example:

12:45:10 - This is the timestamp of the log and should match the time of the RmiServer error message seen in the Java Client (e.g ErrorMsg: AwE-5123 Email error (1/24/25 12:45 PM))

TEST_Notification - This is the name of the Notification object that is throwing the error

TEST_JOB - This is the name of the Job that triggered the notification

[email protected]@email.com - This is the illegal value. In this example, the email value is missing a semi colon in between the 2 email addresses. Because the semi colon is missing, the 2 email addresses is read as one email address containing an illegal second '@' character. 

 

To resolve the error, edit the notification and fix the email value. In this case, adding a semi colon so the email value is "[email protected];[email protected]" or "[email protected]; [email protected]"