Aria Operations for Logs Integrated Load Balancer (VIP) is showing as Unavailable
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Aria Operations for Logs Integrated Load Balancer (VIP) is showing as Unavailable

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Article ID: 387329

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Updated On:

Products

VCF Operations/Automation (formerly VMware Aria Suite)

Issue/Introduction

  • Integrated Load Balancer (VIP) is showing as "Unavailable" on cluster view.
  • Operations for Logs cluster nodes are all showing online.
  • Logging in to all other Operations for Logs node's UI shows the same online status.
  • Logs from external sources are being ingested by Operations for Logs
  • The following errors can be seen from the runtime.log (/storage/core/loginsight/var) on the problematic node:

    ERROR [com.vmware.loginsight.analytics.distributed.AbstractSearchResponseAggregator] [Partial results are being returned as 1 out of 4 nodes failed to respond.  Request token xxxxxxxxxxxxx. Please contact an admin user for more information.]

    ["LoadBalancerStateUpdaterScheduler-thread-1"xxx.xxx.xxx.xxx ERROR] [com.vmware.loginsight.loadbalancer.LoadBalancerPeerMonitor] [LoadBalancerViolation - No load balancer leader found for last 19 minutes]

Environment

Aria Operations for Logs 8.18

VCF Operations Logs 9.x 

Cause

On one of the node, prior memory issue may have caused the VIP to latch on pre-existing status and did not reset to correct status.

Resolution

Shutdown and reboot all cluster nodes in vCenter.

Upon reboot completion, VIP status resets and shows correct "Available" Status.