Reinitialization of nas probe db files via delete causing error
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Reinitialization of nas probe db files via delete causing error

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Article ID: 387320

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Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM) CA Unified Infrastructure Management On-Premise (Nimsoft / UIM) CA Unified Infrastructure Management SaaS (Nimsoft / UIM)

Issue/Introduction

We deleted the ../nas/*.db files from that nas probe directory to clear up an issue and now we are seeing the following error in the nas.log:

nas: ndbTableInsert error: error, 'table NAS_EVENTS has no column named externalId

Environment

  • DX UIM version: 23.4.3
  • Component: nas 23.4.3

Cause

This is a version specific issue with the nas probe that is contained in CU3 of 23.4. 

nas v23.4 may also throw errors such as:

Can not start nas, start after probe not enabled ()

or

Auto-adjusted replication blocksize down to 1, this could indicate a slow transfer rate to '<hub_example>'.

Resolution

Steps to deploy the update:

  1. Download the nas hotfixed version 23.4.3.2 (attached to this article)
  2. Select the Archive icon in IM and rt-click to Import it into your local archive on the Primary hub
  3. Deploy it to the Primary hub or Secondary if you have nas running on a Secondary hub
  4. Using Raw configure, set the loglevel to 3 for each nas instance
  5. Under nas setup, add a logsize key and set it to 5000.
  6. Deactivate the nas
  7. Remove the .db files from the nas probe directory
  8. Activate the nas
  9. While holding down the SHIFT key, double-click the nas probe.
  10. The nas should open successfully

Attachments

nas-23.4.3.2.zip get_app