Multiple Licenses Assigned to a Single ESXi Host & Expired License in inventory Warning in vCenter
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Multiple Licenses Assigned to a Single ESXi Host & Expired License in inventory Warning in vCenter

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Article ID: 387263

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Updated On:

Products

VMware vCenter Server

Issue/Introduction

Symptoms: 

After upgrading vCenter Server to a newer version, the following alert may be triggered

Validation Steps :

  • There will be two licenses for one Esxi host  (One shows as expired other one shows actual assigned license)

            Path to check license:  vSphere --> Administration -->license -->assets-->Solutions 

     

  • Once it is confirmed that two licenses are assigned to an ESXi host, the active license in use by the ESXi host must be verified

             Path : vSphere --> Hosts and clusters --> Select host --> Configure --> Licensing 

   

 

Environment

VMware vSphere 6.x

VMware vSphere 7.x

VMware vSphere 8.x

VCenters are in Enhanced linked mode 

Cause

This issue can occur due to a stale license entry in the VMware Directory Services database

The expired license, although not valid, is still listed as assigned to the host, causing a conflict in the system's ability to remove it. It is also possible that the Enhanced Linked Mode setup contributes to license synchronization complexities across multiple vCenter instances 

 

 

Resolution

1. Make sure you take a non-memory snapshot of the vCSA VM before proceeding with the workaround (powered-down snapshots of all nodes if you have multiple vCenter Servers in Enhanced Linked Mode (ELM).

      VM powered down snapshot:

    1. Go to the Local ESXi web console on the host that the vCenter VM is on
    2. Go to VM
    3. Actions
    4. Guest OS shutdown
    5. Take a Snapshot and name it accordingly
    6. Power the VM back up
    7. Wait for all services to start

Caution:

  • Offline snapshot is a MUST when using lsdoctor tool unless using the --lscheck switch (only) which is used to check for common issues in the lookup service.
  • Make sure there is no backup task running before taking the snapshot of the vCenter Server or the PSC.
  • Do not take snapshot of the vCenter VM(s) if it’s part of vCenter High Availability (VCHA) configuration.  

  Please follow pre-requites mentioned in KB: 313886 and take an offline snapshot of both the VCenters 

2. Log into JXplorer and follow below actions 

      1. Download and install JXplorer, available at JXplorer.

       2. Open JXplorer and select File > Connect.

       3.In the Open LDAP/DSML pane, make these configuration changes:

      1. For host, enter the FQDN of your Platform Services Controller.
      2. The Port should be 389 or 11711.
      3. The protocol is LDAP v3.
      4. Base DN will be dc=vsphere,dc=local.
Note: If you are using a custom vCenter Single Sign-on domain name, you have to replace vsphere and local with the name of your custom domain name. For example, if you chose vsphere.vmware.corp as your vCenter Single Sign-on domain, the value would be: dc=vsphere,dc=vmware,dc=corp

           5. The Security Level will be User + Password.

           6. The Security User DN will be cn=administrator,cn=users,dc=vsphere,dc=local.

           7. The Security Password will be your administrator password for your vCenter Single Sign-on administrator account.

           8. Expand Services > LicenseService.

           9. Select the affected host id ( To take host id goto vpshere --> select the host --> from the url --> select domain=host-xx) 

           For host-38 vmwLicSvcAssestEvalExpiry was set to older date 

Upon validation we could see one entry contains all relevant information with proper vmwLicSvcAssestEvalExpiry date for host-38. 

Below diagram with proper information 

 

   10. Remove the affected AssetEntity_host-ID-UUID.

     Warning: Do not attempt to remove or modify any objects that do not begin with AssetEntity_host-. Removing or modifying these objects may require a clean reinstall  of vCenter and the Platform Services Controller without preserving vCenter Single Sign-on data.
 

    1. Right-click on the entry to remove.
    2. Select Delete.