Skyline Health Alert -- "vSAN cluster configuration consistency" -- Deduplication & Compression is disabled but should be enabled
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Skyline Health Alert -- "vSAN cluster configuration consistency" -- Deduplication & Compression is disabled but should be enabled

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Article ID: 387247

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Updated On:

Products

VMware vSAN 7.x VMware vSAN 8.x

Issue/Introduction

After new Host(s) were added to an existing vSAN Cluster, Skyline Health is showing the following error:

 

The Hosts listed in the Alert are the newly added Host(s).
Clicking "Remediate inconsistent configuration" does not fix the issue

 

Environment

vSAN 7.x
vSAN 8.x

Cause

Inconsistency in Cluster configuration caused by the fact that the newly added Host(s) are not on the same Build as existing Hosts in the Cluster.

 

Resolution

The newly added Host(s) need to be brought to the same Build as the existing Hosts, along with their Disk Groups need to be destroyed and recreated.
 
1.) Put one of the newly added Host(s) in Maintenance Mode with "Ensure Accessibility" (wait for the Task to complete)
5.) Upgrade/Downgrade the Host incl. Reboot (= in order to have the Host being on the same Build/Version as the existing vSAN Hosts)
6.) Add Host back into the Cluster (ensure Task completes)
8.) After the Disk Group(s) have been created, verify that the Disk Group(s) showing as healthy (= green) in the Disk Management
9.) If the Disk Group(s) showing as healthy (= green), put Host out of Maintenance Mode and wait for any Resync to complete
10.) Repeat Steps 1-9 with any remaining newly added Host(s)
11.) Evaluate whether the alert still exists by hitting "Retest" in Skyline Health
12.) If the issue still persists, open a Ticket please open a Ticket with VMware by Broadcom Support.
 

Additional Information