Tanzu Cloud Service Broker for AWS Upgrade From v1.12 to v1.13 Fails - 502 Bad Gateway
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Tanzu Cloud Service Broker for AWS Upgrade From v1.12 to v1.13 Fails - 502 Bad Gateway

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Article ID: 387235

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Updated On:

Products

VMware Tanzu Platform

Issue/Introduction

Version 1.13 and above of the Cloud Service Broker for AWS now deploys the CSB as a Bosh-managed VM. In previous versions, the cloud service broker was a Cloud Foundry application. 

v1.13 Release Notes

 

Customer's may run into the below '502 Bad Gateway' error when trying to install v1.13 and above.

Job (38119164-f1d0-4521-9d74-785651ae1927) failed: The service broker returned an invalid response. Status Code: 502 Bad Gateway, Body: 502 Bad Gateway: Registered endpoint failed to handle the request.

 

Bosh Task Debug Output:

"timestamp": "1738269498.525886297", "source": "Cloud-service-broker", "message": "Cloud-service-broker Database Setup", "10g_level";2, "data": ("error": "dial top 10.217.231.152:3306: 1/0 timeout "})

Cause

'502 Bad Gateway' installation failure may occur if the user doesn't setup the necessary new firewalls/security groups in AWS to allow communication from the Cloud Service Broker VM to the database. Security groups act as virtual firewalls that control inbound and outbound traffic to RDS instances.

Resolution

In the AWS Console, create a network firewall rule to allow the broker VMs to communicate with the AWS RDS instance.

https://docs.aws.amazon.com/AmazonRDS/latest/UserGuide/Overview.RDSSecurityGroups.html?

https://docs.aws.amazon.com/network-firewall/latest/developerguide/getting-started.html